Aporte: Configuracion VPN sobre Balanceo de Carga PCC

Tema en 'Balanceo de Carga (Load Balance)' comenzado por ragis, 25 de Junio de 2017.

  1. ragis

    ragis New Member

    Hace pocos días llegue a este foro con esta inquietud, gracias a un tip que me dio MikrotikPeru logre configurar una VPN-PPTP (aplica para todos los protocolos VPN), sobre un Balanceo de Carga PCC. Comparto la configuración y explico mas abajo.

    Características del equipo y configuración
    RB: 951G-2HnD
    RouterOs: 6.39.2

    Ether1=WAN1: Módem ADSL IP Dinámica, 10Mbps
    Ether2=WAN2: Módem ADSL IP Dinámica, 6Mbps
    Ether3=LAN: Red local
    Ether4=Off
    Ether5=Off


    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=TRAFICO VPN in-interface=all-ppp new-connection-mark=mc_vpn passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=mc_vpn new-routing-mark=mr_vpn passthrough=no

    /ip route
    add check-gateway=ping distance=1 gateway=WAN1 routing-mark="to_WAN1, mr_vpn"
    add check-gateway=ping distance=1 gateway=WAN2 routing-mark="to_WAN2"

    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=LAN


    Explicación
    Lograba conectarme a mi servidor VPN-PPTP pero no me respondía los pings a mi RB ni a ningún dispositivo de mi LAN y mucho menos podía conectarme a alguno de ellos por SSH, TELNET o RDP...Manos a la obra, lo primero que hay que hacer es marcar el trafico PPP (all-ppp) y elegir una WAN por donde va a salir la VPN, en mi caso elegí la WAN1 (mr_vpn), pero seguía igual...en estos casos en IP->ARP en la Interface LAN se pone PROXY-ARP, pero si tenemos un amarre IP este valor sería REPLY-ONLY como en mi caso, hasta que MikrotikPeru me propone enmascarar mi LAN, aplique la regla al NAT y...acá estoy dando las gracias.
     
    Última modificación: 25 de Junio de 2017
    A MikrotikPeru le gusta esto.
  2. MikrotikPeru

    MikrotikPeru Well-Known Member

    Excelente aporte.

    Saludos,
     

Comparte esta página