Aporte Script para enviar log por email

Tema en 'Scripting & Scheduling' comenzado por DaLiCaM, 24 de Noviembre de 2016.

  1. DaLiCaM

    DaLiCaM New Member

    Este script supone que ya tenemos configurado nuestra cuenta de Email (gmail) en nuestro mk, espero les sea de utilidad
    Código (Text):
    /log print file=log-mikrotik.txt

    :log info message="enviando log por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="tucuenta@gmail.com" subject="log-mikrotik $data $hora" file=log-mikrotik.txt body="log-mikrotik $data $hora"
    El primer comando del Script vuelca el log al archivo log-mikrotik.txt
    la segunda linea, genera un evento de nombre "enviando log por email" visible en el log
    la tercera y cuarta linea, capturan la fecha y hora del sistema
    la cuarta linea envía un email con nuestro archivo de log adjunto "log-mikrotik", con titulo y cuerpo log-mikrotik fecha y hora.
    Si deseamos se puede automatizar añadiendo un Shedduler
    Espero les sea de utilidad
     
    A MikrotikPeru le gusta esto.

Comparte esta página