Ayuda con uso de variables en Netwatch

Tema en 'Scripting & Scheduling' comenzado por DaLiCaM, 6 de Febrero de 2018.

  1. DaLiCaM

    DaLiCaM New Member

    Buenas tardes comunidad
    Quisiera que me ayuden con un detalle, tengo en netwatch un script que verifica cuando hay caída de internet, suponiendo que no hay conectividad hacia internet a las 10:25 am, capturar esa hora en una variable y usarla para enviar un reporte del incidente cuando se restablezca la conectividad, digo esto ya que actualmente no tengo una conexión de respaldo.
    Actualmente tengo el script Netwatch de la siguiente forma:

    Up:

    PHP:
    :local fechaup [/system clock get date]
    :local horaup [/system clock get time]
    :log info "Internet está en linea a las $horaup horas fecha $fechaup"
    :tool e-mail send to=correo1@dominio.com cc=corre2@dominio.com  body="Se ha restablecido la conectividad a internet, a las $hora del día $fechaup, pero hubo una caida a las $horadown del día $fechadown" subject="Mensaje Automático de restablecimiento del Servicio de Internet Mikrotik"
    :log info "Ha sido enviado un email de restablecimiento de Servicio de Internet por correo electronico el dia $fechaup a las $horaup"
    Down:

    PHP:
    :local fechaup [/system clock get date]
    :local horaup [/system clock get time]
    :log info "Internet está en linea a las $horaup horas fecha $fechaup"
    :tool e-mail send to=correo1@dominio.com cc=corre2@dominio.com  body="Se ha restablecido la conectividad a internet, a las $hora del día $fechaup, pero hubo una caida a las $horadown del día $fechadown" subject="Mensaje Automático de restablecimiento del Servicio de Internet Mikrotik"
    :log info "Ha sido enviado un email de restablecimiento de Servicio de Internet por correo electronico el dia $fechaup a las $horaup"
     
    Espero me puedan ayudar.

    Saludos,
     
    Última modificación por un moderador: 8 de Febrero de 2018
  2. MikrotikPeru

    MikrotikPeru Well-Known Member

    Ahí falta algún comando de ping, donde pueda verificar el estado, pero .... si no hay internet como sale el correo? a menos que mandes un SMS.
     
  3. DaLiCaM

    DaLiCaM New Member

    De eso se trata de envíar el email cuando regrese, quería saber si hay una forma de capturar esa variable de hora, cuando el ping no obtiene respuesta, por otro lado lo del sms, funciona siempre y cuando tengas la linea de intenet saliendo por un chip 3G o 4G.

    Saludos,
     

Comparte esta página