Bajar resolución o calidad Youtube a 240p ahorro de ancho de banda por usuario mikrotik

Tema en 'Queues' comenzado por MikrotikPeru, 27 de Abril de 2016.

  1. MikrotikPeru

    MikrotikPeru Well-Known Member

    [​IMG]
    PHP:
    /ip firewall mangle
    add action=add-dst-to-address-list address-list=Youtube chain=forward content=googlevideo.com dst-port=80,443 log=yes protocol=tcp
    add action=mark-connection chain=forward dst-address-list=Youtube new-connection-mark=Youtube
    add action=mark-packet chain=forward connection-mark=Youtube new-packet-mark=Youtube
    PHP:
    /queue type
    add kind=pcq name=Youtube144p pcq-classifier=dst-address pcq-rate=420k
    PHP:
    /queue tree
    add name=Youtube144P packet-mark=Youtube parent=ether5 priority=1 queue=Youtube144p
    Con ello podemos ahorrar mucho ancho de banda, en videos muchas veces que deseamos escuchar musica en vez de ver de ser muy exigentes en la calidad de video.
     
  2. Joseph4ever

    Joseph4ever New Member

    Esto me funciona para enviar youtube a una sola WAN?
     
  3. MikrotikPeru

    MikrotikPeru Well-Known Member

  4. saintdave

    saintdave New Member

    Haber si entendi, cuando vea un video de YouTube me baja la velocidad como ej. lo que pusiste a 420kbps de esa forma YouTube detecta mi velocidad baja y me manda automáticamente a 144p, es así como funciona?
     
  5. MikrotikPeru

    MikrotikPeru Well-Known Member

    Correcto amigo, si hubiese otra forma a la orden.
     
  6. LITE_SEVEN

    LITE_SEVEN New Member

    Un favor el ether 5 que interface es lan o wan
     
  7. MikrotikPeru

    MikrotikPeru Well-Known Member

    hola LITE_SEVEN es la interface que da hacia los clientes "Lan"
     
  8. lantiano

    lantiano Member

    Hola , y que pasa si el cliente mismo sube la resolución manualmente ???

    Se ejecutaría a esta nueva resolución, o no cambiaría ???

    Gracias
     
  9. MikrotikPeru

    MikrotikPeru Well-Known Member

    Creo que volveria a 240p por la falta de ancho de banda, a menos que lo exija a youtube y este lo deje parandose a cada rato.
     
  10. lantiano

    lantiano Member

    Osea que con este comando estas asignando como ancho de banda a youtube 420k ??

    En si eso es lo q hace este comando ???
     
  11. MikrotikPeru

    MikrotikPeru Well-Known Member

    Correcto al grupo de stream de youtube por ip local 420kb --> 144p
     
  12. lantiano

    lantiano Member


    Hola mi estimado y para una resolución de unos 360 p cuanto de nacho de banda se usaría ???

    En que te basas para calcular el ancho de banda para cada calidad de vídeo ???
     
  13. MikrotikPeru

    MikrotikPeru Well-Known Member

    Me baso en el uso de ancho de banda visto por el queues simples poniendo manualmente 244p lo mismo podrías calcular para la nueva resolución 360p.
     
  14. lantiano

    lantiano Member

    No entiendo la relación .

    Lo que me quieres decir es que :

    420kb ------------------------- 144 p
    x -------------------------360 p

    De esta manera ???
     
  15. MikrotikPeru

    MikrotikPeru Well-Known Member

    Regla de tres simple pixel x kilobits :D , no es tanto asi si no calculo en base a un torch mikrotik o en base a la IP publica cuando cargo un video youtube o en el peor de los casos en queues simples cargando solo el video amigo.
     
  16. saintdave

    saintdave New Member

    Que yo sepa youtube por default de trabaja a 360 aunque tengas 10mb, si quieres que te trabaje a menos de 360 ahi si necesitas usar este tuto ya sea a 240 0 144, por ahi lei que decia que pasa si el usuario sube la calidad de video en el mismo youtube obvio que va obedecer lo que le ordenen.
     
    A MikrotikPeru le gusta esto.
  17. Barnabas Collins

    Barnabas Collins New Member

    Muy buena regla lo que mas me agrada es que le asigna el ancho de banda a cada ip de toda la red automáticamente , mi pregunta ahora es habrá otra regla que cumpla la misma función pero con el facebook? :D , gracias por compartir.
     
  18. MikrotikPeru

    MikrotikPeru Well-Known Member

  19. Deivico

    Deivico New Member

    Muchísimas gracias, me ha sido muy útil esta regla pero me gustaría saber si hay forma de crear una excepción para una sola ip, de antemano gracias por la ayuda
     
  20. MikrotikPeru

    MikrotikPeru Well-Known Member

    Entonces crearías en ip fi address-list con nombre "users-sin-qos" para aquellos usuarios que no quieres que pasen por el qos de youtube

    PHP:
    /ip firewall mangle
    add action=add-dst-to-address-list address-list=Youtube chain=forward content=googlevideo.com dst-port=80,443 protocol=tcp
    add action=mark-connection chain=forward dst-address-list=Youtube new-connection-mark=Youtube src-address-list=!users-sin-qos
    add action=mark-packet chain=forward connection-mark=Youtube new-packet-mark=Youtube
    Saludos,
     

Comparte esta página