balanceo 4 lineas falta algo para mejorar?

Tema en 'Balanceo de Carga (Load Balance)' comenzado por jairoortega, 9 de Mayo de 2017.

  1. jairoortega

    jairoortega New Member

    /ip firewall mangle
    add action=accept chain=prerouting dst-address=192.168.2.0/24 in-interface=\
    bridge1
    add action=accept chain=prerouting dst-address=192.168.3.0/24 in-interface=\
    bridge1
    add action=accept chain=prerouting dst-address=192.168.4.0/24 in-interface=\
    bridge1
    add action=accept chain=prerouting dst-address=(ip publica va aqui) in-interface=\
    bridge1
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=WAN1 log=yes new-connection-mark=WAN1_con passthrough=yes
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=WAN2 new-connection-mark=WAN2_con passthrough=yes
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=WAN3 new-connection-mark=WAN3_con passthrough=yes
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=WAN4 new-connection-mark=WAN4_con passthrough=yes
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local in-interface=bridge1 new-connection-mark=WAN1_con \
    passthrough=yes per-connection-classifier=both-addresses:4/0
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local in-interface=bridge1 new-connection-mark=WAN2_con \
    passthrough=yes per-connection-classifier=both-addresses:4/1
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local in-interface=bridge1 new-connection-mark=WAN3_con \
    passthrough=yes per-connection-classifier=both-addresses:4/2
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    dst-address-type=!local in-interface=bridge1 new-connection-mark=WAN4_con \
    passthrough=yes per-connection-classifier=both-addresses:4/3
    add action=mark-routing chain=prerouting connection-mark=WAN1_con in-interface=\
    bridge1 new-routing-mark=to_WAN1 passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=WAN2_con in-interface=\
    bridge1 new-routing-mark=to_WAN2 passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=WAN3_con in-interface=\
    bridge1 new-routing-mark=to_WAN3 passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=WAN4_con in-interface=\
    bridge1 new-routing-mark=to_WAN4 passthrough=yes
    add action=mark-routing chain=output connection-mark=WAN1_con new-routing-mark=\
    to_WAN1 passthrough=yes
    add action=mark-routing chain=output connection-mark=WAN2_con new-routing-mark=\
    to_WAN2 passthrough=yes
    add action=mark-routing chain=output connection-mark=WAN3_con new-routing-mark=\
    to_WAN3 passthrough=yes
    add action=mark-routing chain=output connection-mark=WAN4_con new-routing-mark=\
    to_WAN4 passthrough=yes
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=WAN2
    add action=masquerade chain=srcnat out-interface=WAN3
    add action=masquerade chain=srcnat out-interface=WAN4
    add action=masquerade chain=srcnat out-interface=WAN1
    /ip route
    add check-gateway=ping distance=1 gateway=192.168.2.1 routing-m
    add check-gateway=ping distance=1 gateway=192.168.3.1 routing-m
    add check-gateway=ping distance=1 gateway=192.168.4.1 routing-m
    add check-gateway=ping distance=1 gateway=(ip publica va aqui) routing
    add check-gateway=ping distance=1 gateway=192.168.2.1
    add check-gateway=ping distance=1 gateway=192.168.3.1
    add check-gateway=ping distance=1 gateway=192.168.4.1
    add check-gateway=ping distance=1 gateway=(ip publica va aqui)
     
  2. daviddomh

    daviddomh New Member

    porque ip publica?? si tu modem esta en modo bridge deberia ir PPPoE1
     
  3. Howard Smith

    Howard Smith Member

    Está bien. Pero como dice David, en IP ROUTE pondras la ip publica ?
    tienes que poner la interface o el gateway de la ip publica en caso que trabajas con ip publica en el mikrotik
    Nota:Si el mikrotik tendrá una ip publica ya sea por pppoe o directamente, tienes que habilitar si o si el Firewall y poner unas reglas .
     
  4. Howard Smith

    Howard Smith Member

    te dejo esta guía para que lo apliques a cada interface WAN1 , WAN2,WAN3.
     
  5. daviddomh

    daviddomh New Member

    Mi pregunta es funciona este balanceo , como por ejemplo mandar youtube por wan1, Juegos a Wan2 , Navegaciòn a Wan3 y update de steam y otros Juegos a wan4 ???
    q sepa es otro tipo de balanceo
     

Comparte esta página