Balanceo de carga por IP origen a determinados gateway - Enrutamiento estatico

Tema en 'Balanceo de Carga (Load Balance)' comenzado por MikrotikPeru, 22 de Agosto de 2016.

  1. MikrotikPeru

    MikrotikPeru Well-Known Member

    El manejo del ancho de banda es una parte escencial del trabajo diario de todo ISP, usuario comercial o doméstico. Hay varias formas diferentes de hacer esto con el RouterOS Mikrotik ya sea usando QoS, Limite de tasa de transferencia, limite de paquetes, solo por nombrar algunos En lo personal, el autor del presente, es administrador de un ISP que presta servicio inalámbrico en una zona donde no hay otro proveedor de conexiones de banda ancha (Ej.: Cable, Fibra, ADSL, etc).

    Funciones del RouteOS Utilizadas aquí
    • Firewall mangle rules
    • Firewall address-lists
    • Routing

    Paso 1 - Configurando la red
    Para empezar a desarrollar este tutorial, necesitamos una red ficticia que usaremos como ejemplo
    • Computadoras Cliente (172.18.1.0/24)
    • Internet Gateways (10.0.1.1/24, 10 0.2.1/24)
    • RouterOS IPs (10.0.1.2/24, 10.0.2.2/24)
    [​IMG]

    Ruteo Agrupando en address-list
    PHP:
    /ip firewall address-list
    add list="WAN-01" address=172.18.1.24/32 comment="" disabled=no
    add list="WAN-02" address=172.18.1.76/32 comment="" disabled=no
    PHP:
    /ip firewall nat
    add chain=srcnat action=masquerade out-interface="WAN - 01" src-address-list="Allowed - Internet" comment="Gateway 10.0.1.1/24" disabled=no
    add chain=srcnat action=masquerade out-interface="WAN - 02" src-address-list="Allowed - Internet" comment="Gateway 10.0.2.1/24" disabled=no
    Ruteo por IP
    PHP:
    /ip firewall mangle add chain=prerouting src-address=172.18.1.24 dst-address-type=!local action=mark-routing new-routing-mark
    =ruta1
    PHP:
    /ip firewall mangle add chain=prerouting src-address=172.18.1.76 dst-address-type=!local action=mark-routing new-routing-mark
    =ruta2
    Lo mas importante por donde va salir el internet o las rutas que tomara
    PHP:

    /ip route add dst-address=0.0.0.0/0 gateway=10.0.1.1 routing-mark=ruta1
    /ip route add dst-address=0.0.0.0/0 gateway=10.0.2.1 routing-mark=ruta2
    /ip route add dst-address=0.0.0.0/0 gateway=10.0.1.1 distance=1
    /ip route add dst-address=0.0.0.0/0 gateway=10.0.2.1 distance=2
     
    Paso 5 - Revisión de lo que se hizo
    Que fué lo que hizo?:

    • Usted inteligentemente separó su tráfico en diferentes tipos
    • Usted marcó paquetes usando la herramienta Mangle
    • Usted creó una lista especial para aquellos clientes que NO puedan salir por el balanceo de carga
    • Usted asignó una rura particular para cada paqueta marcado en el Mangle
     
    Última modificación: 22 de Agosto de 2016
  2. aderyq

    aderyq New Member

    Buen material MIKROTIK PERU una duda ahi falta configurar lod DNS el LAN IP ADRESS SERIA GENIAL SI PODRIAS AYUDARME GRACIAS
     
  3. MikrotikPeru

    MikrotikPeru Well-Known Member

    Siempre que sea por este medio a la orden así apoyamos a todos.

    Saludos,
     
  4. girley23

    girley23 New Member

    HOLA: amigo soy nuevo por aqui, me gustaria que me ayudaran a hacer la configuracion de este tipo de balanceo.. la verdad tengo un balaceador rb750 y un administrador rb2011 ,, no se si deberia utilizar solo la rb 2011 para encargarse de administar y balancear... pero el internet esta muy lento cuando desconecto una de las lineas si trabaja bn el internet,, por favor ayudemen aa relaizar la configuracion
     
  5. MikrotikPeru

    MikrotikPeru Well-Known Member

    Realizar la configuración que quieres te recomendaría que lo hagas con un equipo todo, si no te vas a complicar, ahora que quieras si o si poner los dos equipos, bien vas a tener que Enrutar en el balanceador o activar OSPF, Para que tu balanceador pueda ver el trafico origen y asi redireccionar tu trafico a tu gusto.

    Saludos,
     

Comparte esta página