BGP sobre Tunnel Gre

Tema en 'General' comenzado por Howard Smith, 12 de Diciembre de 2017.

  1. Howard Smith

    Howard Smith Member

    [​IMG]

    ISP

    Código (Text):
    username hq password 0 cisco
    username rocio password 0 cisco
    !
    bba-group pppoe LABGROUP
    virtual-template 1
    !
    interface Multilink1
    ip address 10.10.20.1 255.255.255.0
    ppp authentication chap
    ppp multilink
    ppp multilink group 1
    !
    interface FastEthernet0/0
    no ip address
    pppoe enable group LABGROUP
    !
    interface Serial0/0
    no ip address
    encapsulation ppp
    clock rate 2000000
    ppp multilink
    ppp multilink group 1
    !
    interface Serial0/2
    no ip address
    encapsulation ppp
    clock rate 2000000
    ppp multilink
    ppp multilink group 1
    !
    interface Serial0/1
    ip address 10.10.30.1 255.255.255.252
    encapsulation ppp
    clock rate 2000000
    ppp authentication pap
    ppp pap sent-username santos password 0 cisco
    !
    interface Virtual-Template1
    ip address 10.10.10.1 255.255.255.0
    peer default ip address pool DIRECCIONES
    !
    ip local pool DIRECCIONES 10.10.10.100 10.10.10.254
    ip forward-protocol nd
    ip route 172.16.10.0 255.255.255.0 10.10.10.100
    ip route 172.16.20.0 255.255.255.0 10.10.20.2
    ip route 172.16.30.0 255.255.255.0 10.10.30.2
    BRANCH1
    Código (Text):
    interface Tunnel0
    ip address 172.16.1.2 255.255.255.0
    tunnel source Dialer1
    tunnel destination 10.10.20.2
    !
    interface FastEthernet0/0
    no ip address
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    interface FastEthernet0/1
    ip address 172.16.10.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface Dialer1
    mtu 1492
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    !
    router bgp 65010
    no synchronization
    bgp log-neighbor-changes
    network 172.16.1.0 mask 255.255.255.0
    network 172.16.10.0 mask 255.255.255.0
    neighbor 172.16.1.1 remote-as 65030
    no auto-summary
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 10.10.10.1
    ip route 10.10.20.2 255.255.255.255 FastEthernet0/0

    HQ


    Código (Text):
    interface Tunnel0
    ip address 172.16.1.1 255.255.255.0
    tunnel source Multilink1
    tunnel destination 10.10.10.100
    !
    username ISP password 0 cisco
    !
    hostname hq
    !
    interface Tunnel2
    ip address 172.16.2.1 255.255.255.0
    tunnel source Multilink1
    tunnel destination 10.10.30.2
    !
    interface Multilink1
    ip address 10.10.20.2 255.255.255.0
    ppp authentication chap
    ppp multilink
    ppp multilink group 1
    !
    interface Serial0/0
    no ip address
    encapsulation ppp
    !
    ppp multilink
    ppp multilink group 1
    !
    interface FastEthernet0/1
    ip address 172.16.20.1 255.255.255.0
    !
    interface Serial0/2
    no ip address
    encapsulation ppp
    clock rate 2000000
    ppp multilink
    ppp multilink group 1
    !
    router bgp 65030
    network 172.16.1.0 mask 255.255.255.0
    network 172.16.2.0 mask 255.255.255.0
    network 172.16.20.0 mask 255.255.255.0
    neighbor 172.16.1.2 remote-as 65010
    neighbor 172.16.2.2 remote-as 65040
    no auto-summary
    !
    ip route 0.0.0.0 0.0.0.0 10.10.20.1
    ip route 10.10.10.100 255.255.255.255 Multilink1
    ip route 10.10.30.2 255.255.255.255 Multilink1
     
    BRANCH2
    Código (Text):
    username santos password 0 cisco
    interface Tunnel0
    ip address 172.16.1.2 255.255.255.0
    !
    interface Tunnel2
    ip address 172.16.2.2 255.255.255.0
    tunnel source Serial0/1
    tunnel destination 10.10.20.2
    !
    interface FastEthernet0/1
    ip address 172.16.30.1 255.255.255.0
    !
    interface Serial0/1
    ip address 10.10.30.2 255.255.255.252
    encapsulation ppp
    ppp authentication pap
    ppp pap sent-username rocio password 0 cisco
    !
    router bgp 65040
    network 172.16.2.0 mask 255.255.255.0
    network 172.16.30.0 mask 255.255.255.0
    neighbor 172.16.2.1 remote-as 65030
    no auto-summary
    !
    ip route 0.0.0.0 0.0.0.0 10.10.30.1
    ip route 10.10.20.2 255.255.255.255 Serial0/1
     
    Última modificación: 12 de Diciembre de 2017

Comparte esta página