Calidad de Servicio (QoS) MIKROTIK ACTUALIZADO V6

Tema en 'Queues' comenzado por MikrotikPeru, 19 de Febrero de 2016.

  1. MikrotikPeru

    MikrotikPeru Well-Known Member

    MARCAMOS LOS PAQUETES

    Código (Text):
    /ip firewall mangle
    add action=mark-connection chain=forward comment="PRIO-8  P2P" new-connection-mark="PRIO 8" p2p=all-p2p
    add action=mark-packet chain=forward connection-mark="PRIO 8" new-packet-mark="PRIO 8_up" passthrough=no src-address-list=Clientes
    add action=mark-packet chain=forward connection-mark="PRIO 8" dst-address-list=Clientes new-packet-mark="PRIO 8_down" passthrough=no
    add action=mark-connection chain=forward comment="PRIO - 7 MULTIDESCARGAS" connection-bytes=50000000-0 new-connection-mark="PRIO 7" \
        protocol=tcp
    add action=mark-packet chain=forward connection-mark="PRIO 7" new-packet-mark="PRIO 7_up" passthrough=no src-address-list=Clientes
    add action=mark-packet chain=forward connection-mark="PRIO 7" dst-address-list=Clientes new-packet-mark="PRIO 7_down" passthrough=no
    add action=mark-connection chain=forward comment="MARCO PRIO 1" new-connection-mark="PRIO 1" protocol=icmp
    add action=mark-connection chain=forward dst-address=192.95.62.41 new-connection-mark="PRIO 1"
    add action=mark-connection chain=forward dst-port=53 new-connection-mark="PRIO 1" protocol=udp
    add action=mark-packet chain=forward connection-mark="PRIO 1" new-packet-mark="PRIO 1_up" passthrough=no src-address-list=Clientes
    add action=mark-packet chain=forward connection-mark="PRIO 1" dst-address-list=Clientes new-packet-mark="PRIO 1_down" passthrough=no
    add action=mark-connection chain=forward comment="MARCO PRIO 2 , STREAMING - JUEGOS,VOIP" dst-port=5060-5061 new-connection-mark=\
        "PRIO 2" protocol=udp
    add action=mark-connection chain=forward dst-port=1863,5190,777 new-connection-mark="PRIO 2" protocol=tcp
    add action=mark-packet chain=forward connection-mark="PRIO 2" new-packet-mark="PRIO 2_up" passthrough=no src-address-list=Clientes
    add action=mark-packet chain=forward connection-mark="PRIO 2" dst-address-list=Clientes new-packet-mark="PRIO 2_down" passthrough=no
    add action=mark-connection chain=forward comment="marco prio 3 navegacion" dst-port=80,443,8000-9000 new-connection-mark="PRIO 3" \
        protocol=tcp
    add action=mark-connection chain=forward dst-port=80,443,8000-9000 new-connection-mark="PRIO 3" protocol=udp
    add action=mark-packet chain=forward connection-mark="PRIO 3" new-packet-mark="PRIO 3_up" passthrough=no src-address-list=Clientes
    add action=mark-packet chain=forward connection-mark="PRIO 3" dst-address-list=Clientes new-packet-mark="PRIO 3_down" passthrough=no
    add action=mark-connection chain=forward comment="PRIO 4 - PUERTOS LABORALES" dst-port=25,110,143,3389,1723,21-23 \
        new-connection-mark="PRIO 4" protocol=tcp
    add action=mark-packet chain=forward connection-mark="PRIO 4" new-packet-mark="PRIO 4_up" passthrough=no src-address-list=Clientes
    add action=mark-packet chain=forward connection-mark="PRIO 4" dst-address-list=Clientes new-packet-mark="PRIO 4_down" passthrough=no
    add action=mark-connection chain=forward comment="MARCO PRIO 5" connection-mark=no-mark new-connection-mark="PRIO 5"
    add action=mark-packet chain=forward connection-mark="PRIO 5" new-packet-mark="PRIO 5_up" passthrough=no src-address-list=Clientes
    add action=mark-packet chain=forward connection-mark="PRIO 5" dst-address-list=Clientes new-packet-mark="PRIO 5_down" passthrough=no


    CREAMOS LA ESTRUCTURA HTB
    Código (Text):
    /queue tree
    add max-limit=8M name=Download parent=global priority=1
    add name=PRIO1 packet-mark="PRIO 1_down" parent=Download priority=1 queue=BAJADA
    add name=PRIO2 packet-mark="PRIO 2_down" parent=Download priority=2 queue=BAJADA
    add name=PRIO3 packet-mark="PRIO 3_down" parent=Download priority=3 queue=BAJADA
    add name=PRIO4 packet-mark="PRIO 4_down" parent=Download priority=4 queue=BAJADA
    add name=PRIO5 packet-mark="PRIO 5_down" parent=Download priority=5 queue=BAJADA
    add name=PRIO7 packet-mark="PRIO 7_down" parent=Download priority=7 queue=BAJADA
    add name=PRIO8 packet-mark="PRIO 8_down" parent=Download queue=BAJADA
    add max-limit=1M name=Upload parent=global priority=1
    add name=PRIO.1 packet-mark="PRIO 1_up" parent=Upload priority=1 queue=SUBIDA
    add name=PRIO.2 packet-mark="PRIO 2_up" parent=Upload priority=2 queue=SUBIDA
    add name=PRIO.3 packet-mark="PRIO 3_up" parent=Upload priority=3 queue=SUBIDA
    add name=PRIO.4 packet-mark="PRIO 4_up" parent=Upload priority=4 queue=SUBIDA
    add name=PRIO.5 packet-mark="PRIO 5_up" parent=Upload priority=5 queue=SUBIDA
    add name=PRIO.7 packet-mark="PRIO 7_up" parent=Upload priority=7 queue=SUBIDA
    add name=PRIO.8 packet-mark="PRIO 8_up" parent=Upload queue=SUBIDA
     
     
    A danielmikrotik y alojarteya les gusta esto.
  2. Zosimo

    Zosimo New Member

    se puede agregar al balanceador con cuatro lineas
     
  3. MikrotikPeru

    MikrotikPeru Well-Known Member

  4. darkhammer

    darkhammer New Member

    cuando colocals GLOBAL quiere dercir que actua sobre todas las interfaces LAn y WAN?
     
  5. MikrotikPeru

    MikrotikPeru Well-Known Member

    Correcto, ya no debes definir cada vez las interfaces de la LAN o WAN.
     
  6. rgchurion

    rgchurion New Member

    Buen día, para controlar ancho de banda de los clientes por QueueTree tendría que usar otra RB ?
     
    Última modificación: 26 de Abril de 2016
  7. rgchurion

    rgchurion New Member

  8. MikrotikPeru

    MikrotikPeru Well-Known Member

    No se puede armar en v6.x Priorizacion y Control de banda en Queues Tree, en versiones 5.x si es posible, es por ello que necesitas de dos Routerboard.
     
  9. MikrotikPeru

    MikrotikPeru Well-Known Member

    En realidad es lo mismo la diferencia entre uno y otro es que puedes trabajar en este actualizado no necesariamente con una interfaces si no por rangos de IPs, que es mucho mejor puesto que puedes tener varias interfaces con diferentes IPs y por cada interfaces no vas a crear una regla nueva por eso se hizo esta nueva manera.
     
  10. WAros

    WAros New Member

    si hacemos este QoS Obligatoriamente tendríamos que controlar el ancho de panda con Queue Simple, esto no bajara el rendimiento ya que siempre han recomendado usar pcq y árbol de colas para controlar el ancho de banda
     
  11. MikrotikPeru

    MikrotikPeru Well-Known Member

    Como comentaba no es posible hacer las dos cosas en V6, ahora necesitas dos RBs para cumplir ese objetivo, sin embargo ha mejorado mucho el uso de queues simples puesto que ahora solo existe global ya no tres como era la version 5.x.
     
  12. WAros

    WAros New Member

    veo que en simple queue se pueden utilizar mark packet oypcq no equivaldría esto hacerlo igual que en queue tree como en version 5x pero en simple queue
     
  13. petikitoz

    petikitoz New Member

    Muy buenas ... hace unos días compre el RB750r2 lo instale y deje las configuración por default ... desde entonces he tratado de crear simple queues pero estas no funcionan, intento limitar de todas las formas pero el ancho de banda sigue sin variar para nada ... estoy usando la v6 de winbox, quisiera saber si estoy haciendo algo mal en la configuración muchas gracias de antemano
     
  14. MikrotikPeru

    MikrotikPeru Well-Known Member

    Si puedes enviar una impresión de pantalla y adjuntando seria ideal para apoyarte.
     
  15. petikitoz

    petikitoz New Member

    Muchas gracias por responder, aqui estan las imagenes antes y despues de crear la simple queue en este caso a mi propia pc.. lo he itentado por queue tree, marcando paquetes y ninguna me dan resultado. que es lo que podria hacer?(si necesita cualquier captura de pantalla o informacion la enviare.. gracias por el apoyo) limitar antes.png limitar despues.png
     
    Última modificación: 3 de Mayo de 2016
  16. MikrotikPeru

    MikrotikPeru Well-Known Member

    La configuracion que estas usando es la que viene por defecto de mikrotik, para este caso la ether1 es WAN y las demas ethernet 2-5 son LAN ese es el concepto, ahora el segmento de LAN que trae por defecto es 192.168.88.1 apartir de ahi deberias trabajar sin inconvenientes.
     
  17. CarlosDark

    CarlosDark New Member

    Buenas Tardes. haber dicen que ahora se necesita dos RBs para poder utilizar esto
    como seria la estructura entonces pues en mi caso yo tengo configurado un rb-1100x2 como balanceador y otro CCR como administrador
    en el CCR admin esta configurado de este modo
    ether1 = wan
    ether2 = reserva
    ether3 = mikrowisp
    ether4 al 11 en LAN bridge
    BANLANCEO
    ether1 al 11 = WAN
    ether12 = LAN
    en cual de ellos va el código o como haría para poder implementarlo adecuadamente.
    Agradeceria mucho su ayuda pues no tengo configurado nada de eso aun.
    Gracias de antemano
     
  18. MikrotikPeru

    MikrotikPeru Well-Known Member

    Excelente pregunta CarlosDark
    El QoS debe ser realizado en el Balanceador pues ahi es en crudo llegan las lineas, no seria real trabajarlo en el administrador pues ahi, ya llegan balanceadas "sumadas", Las lineas en tu caso al parecer 11 lineas te dejo un enlace sobre qos en el balanceador y como es la forma para que lo adecues a tu tipo de balanceo.

    http://www.mikrotikperu.pe/foros/threads/balanceo-de-carga-nth-calidad-de-servicio-solucion.73/

    Saludos,
     
  19. rgchurion

    rgchurion New Member

    Saludos Bernardo, al balancear se usa marcación de conexiones y enrutamiento, al hacer QoS también se realiza marcación de conexiones y paquetes. Pueda equivocarme pero hacer ambas marcaciones (balanceo y QoS) en una misma como que no da buen resultado. Yo diría que si en la RB administradora se usa queue simple se implementara el QoS en la administradora, pero si se usa Queue Tree tendría que recurrir a una tercer RB. (Modems -> RB Balanceo -> RB QoS -> RB Administradora. Me gustaría saber tu opinión al respecto. Gracias.
     
  20. MikrotikPeru

    MikrotikPeru Well-Known Member

    Hola Robert, bienvenido al foro excelente pregunta ya ud viene trabajando con balanceo años, por eso veo muy asertiva y puntual, justo este balanceo y qos que estoy presentando no es necesario usarlo con nth si no también usarlo con pcc, solo marcas en el Balanceo osea en la cadena prerouting y ahí mimo termina el ruteo luwgo Aprovechando esa misma conexión para no volver a marcar usamos pero en l cadena siguiente forward. La pregunta seria por que no en postrouting? Por que no me permite setear interfases origen, en general siempre he recomendado hacer el qos en el balanceador por la sencilla razón que puedes desmenuzar por línea y más rápido hará tu qos por llegar al max-limit.

    Saludos,
     

Comparte esta página