Configurar VPN con PPTP

Tema en 'Sistemas PPP' comenzado por MikrotikPeru, 10 de Febrero de 2016.

  1. MikrotikPeru

    MikrotikPeru Well-Known Member

    ✔ 1. FUNDAMENTOS

    Nuevamente seguimos con las guías , en esta ocasión le traemos un tema muy interesante que facilita la vida a un proveedor de servicio de Internet o empresa, ya que gracias a una vpn puede conectarse a las redes remotas y administrar desde una sola ubicación . Es muy sencillo de implementar no es cosa de otro mundo ,Pero Antes de empezar con el laboratorio veremos un poco de fundamentos .

    1.1 ¿Qué es una Vpn ?
    Básicamente vpn es una red privada virtual en Internet , te permite crear una conexión segura a otra red Wan .Es como si pasaras un cable hasta la red que deseas conectarte , Netamente crea un tunel de comunicación en toda una red. Necesaria para realizar una vpn tiene que existir un Servidor VPN y un cliente VPN

    1.2 ¿Para que lo puedo Usar ?
    Se puede usar para realizar un tunel con otra red y cuando te conectas a la vpn el tráfico es generado desde la base remota es como si estuvieras en dicha base ,por lo tanto puedes conectarte a los recursos de la red remota (Antenas , computadoras , camaras ip ).
    [​IMG]

    Nota:Recuerden que para esta guia el mikrotik tiene que tener la ip publica , Puede estar configurado como PPPoE cliente o obteniendo por dhcp cliente, etc.
    ✔ 2.LABORATORIO
    Bueno compañeros , Manos a la obra, En primera instancia habilitaremos el servicio de VPN .Quiere decir que nuestro Mikrotik funcionara como Servidor .

    [​IMG]

    2.1 Creamos el Perfil
    En esta opción crearemos el perfil de vpn , Solo colocaremos los Dns para que pueda resolver consultas .
    -PPP
    -Profile
    -(+)
    -Dns Server :
    8.8.8.8 , 8.8.4.4
    -ok

    [​IMG]


    2.2 Creando Usuarios
    Crearemos las credenciales correspondientes para que cuando el cliente se conecte al servidor , El mikrotik pueda identificar y aceptar la conexión de el Vpn cliente.
    Para ello seguimos los pasos siguientes.
    -PPP
    -Secret
    -(+)
    -Name:
    Nombre del usuario
    -Password: Contraseña del usuario
    -Service: PptP (Protocolo del VPN )
    -Profile: (Perfil del usuario)
    -Local Addres: (Pondremos nuestra puerta de enlace )
    -Remota Addres: (una ip remota libre en la red para que no haya conflicto)



    [​IMG]

    2.3 Creando Un VPN cliente en Windows

    Un vpn cliente puede ser otro mikrotik o algúnw sistema operativo hasta nuestro propio celular .Para crear un vpn cliente en windows tenemos que ir a la opciòn de centro de redes y recursos compartidos

    -Configurar una nueva Conexión de Red

    [​IMG]

    Le decimos que queremos usar una vpn.

    [​IMG]

    2.4 Conectando con la IP Publica

    Dirección de Intertet: IP Publica del servidor
    Nombre de destino: Un nombre cualquiera

    [​IMG]

    2.5 ¿Cual es mi IP Publica?
    Para ver cual es la ip publica de nuestro mikrotik tenemos que ir ingresar a nuestro servidor y ver que ip le asigno nuestro proveedor de Internet .
    -IP
    -Addresses


    [​IMG]

    2.6 Ingresando Credenciales
    En esta opción ingresaremos las credenciales que creamos anteriormente en el servidor .


    [​IMG]

    2.7 Laboratorio Exitoso

    [​IMG]
     
    Última modificación: 10 de Febrero de 2016
  2. rennar

    rennar New Member

    Buenas tardes, he realizado todos los pasos, me conecto por que se refleja en mi Mikrotik OS 86X, el detalle es que trato de ingresar a la intranet y no entra, trato de hacer ping al servidor de dominio, y tampoco le llego, ingreso a cmd coloco ipconfig, y no me da puerta de enlace, no se si me falta algo mas que configurar...
     
  3. MikrotikPeru

    MikrotikPeru Well-Known Member

    Haz un Proxy-ARP a la interface LAN o bien NATEA la IP del VPN contra el segmento LAN.

    Saludos,
     
  4. rennar

    rennar New Member

    Buenos días, disculpe mi ignorancia pero no le entiendo lo que debo hacer...
     
  5. Howard Smith

    Howard Smith Member

    se refiere que en en la interface ether5 (de tu lan ) le marques la opción proxy-arp . lo que estará haciendo esta opción es que enmascara en capa 2 para que el mikrotik vea la petición como una lan directa.
    Nota: Sin hacer el procedimiento de el proxy-arp la vpn debe funcionar , en la guía está paso por paso , Recuerda que el mikrotik tiene que tener la ip publica o una PPPOE (el modem router en Bridge ) si no tiene ip publica o estas en un NAT3 la vpn no funciona.
     
  6. Howard Smith

    Howard Smith Member

    La ip publica debe estar más o menos de esta manera , [​IMG]
     
  7. rennar

    rennar New Member

    Buenas tardes, estoy trabajando con dns dinamico el detalle es que me conecto a la VPN, pero la misma no me deje navegar dentro de la red, solo me deja conectarme al WinBox,
     
  8. Buenos días, requiero de su amable ayuda, estoy realizando una conexión VPN la cual me permite conectar sin problemas, pero cuando quiero ingresar al servidor solo me permite colocando la IP \\192.168.xxx.xxx, pero colocando el nombre del servidor no me deja ingresar \\geoxxxx alguna solución para esto? gracias.
     
  9. MikrotikPeru

    MikrotikPeru Well-Known Member

    Tiene que ver mucho a que servidor DNS estas apuntando y registrar en ese DNS de Tipo A : IP y su dominio.
    Saludos,
     
  10. ragis

    ragis New Member

    Excelente aporte, tengo dos wan con balance PCC y necesito conectarme por vpn, entiendo que no puedo balancear este tipo conexión, como la configuro para que entre y salga por una única wan? Gracias!!!
     
  11. MikrotikPeru

    MikrotikPeru Well-Known Member

    La idea del balanceo que haya input y/o output bien configurado para que puedas conectar por la publica la VPN.
     
  12. ragis

    ragis New Member

    Gracias por tu pronta respuesta, mi IP publica es dinámica. alguna idea, desde ya muchas gracias....
     
  13. MikrotikPeru

    MikrotikPeru Well-Known Member

    La idea es que sea publica -> Dinámica o Estatica.
    Respeta estas reglas que son cruciales para lo que deseas en un balanceo.

    PHP:
    /ip firewall mangle
    add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=WAN1  new-connection-mark=WAN1_con passthrough=yes
    add action=mark-routing chain=output connection-mark=WAN1_con new-routing-mark=to_WAN1 passthrough=yes
    Saludos,
     
  14. ragis

    ragis New Member

    Estimado, gracias por tu colaboración, pude resolver el problema, es una combinación del mangle y routes voy a postear la solución completa.
     
  15. ragis

    ragis New Member

Comparte esta página