Filtro de Contenidos con Mikrotik Bloqueando Youtube

Tema en 'Firewall' comenzado por MikrotikPeru, 5 de Febrero de 2016.

  1. MikrotikPeru

    MikrotikPeru Well-Known Member

    PHP:
    /ip firewall filter add dst-address-list=Youtube  action=reject chain=forward
    PHP:
    /ip firewall address-list
    add address=190.98.0.0/16 comment=Youtube list=Youtube
    add address=173.194.0.0/16 comment=Youtube list=Youtube
    add address=74.125.0.0/16 comment=Youtube list=Youtube
    add address=181.65.0.0/17 comment=Youtube list=Youtube
    add address=190.235.128.0/17 comment=Youtube list=Youtube
    add address=209.85.0.0/16 comment=Youtube list=Youtube
    add address=216.58.0.0/16 comment=Youtube list=Youtube
    add address=179.6.0.0/16 comment=Youtube list=Youtube
    add address=190.116.0.0/15 comment=Youtube list=Youtube
    Tambien por IPs donde 172.16.80.54 es la IP del usuario

    PHP:

    /ip firewall layer7-protocol
    add name=Youtube regexp="^.*(youtube).*\\\$"
     
    PHP:

    /ip firewall filter
    add action=reject chain=forward dst-address=172.16.80.54 layer7-protocol=Youtube protocol=tcp src-port=80,443
    add action=reject chain=forward dst-address=172.16.80.54 layer7-protocol=Youtube protocol=udp src-port=80,443
     
    Esta información puede variar un poco, dependiendo el PAIS.
     
    Última modificación: 27 de Junio de 2016
  2. juliobrenis

    juliobrenis New Member

    Saludos:
    Con la lista tambien se bloquea Google (buscador) y Gmail, son los 2 servicios de goole que he probado.
    Aplique la siguiente regla:
    ;;; BLOQUEA YOUTUBE
    chain=forward action=reject reject-with=icmp-network-unreachable
    dst-address-list=Youtube in-interface=LAN log=no log-prefix=""
    Gracias por tu pronta respuesta.
     
  3. MikrotikPeru

    MikrotikPeru Well-Known Member

    Compañero , Seria de la siguiente manera en Filter Rules:
    PHP:
    add action=drop chain=forward dst-address-list=Youtube in-interface=ether5
    También lo puedes hacer por Capa7.

    PHP:

    /ip firewall layer7-protocol
    add comment="" name=youtube regexp="^.*(youtube).*\$"
     
     
    Última modificación: 30 de Marzo de 2016
  4. juliobrenis

    juliobrenis New Member

    Gracias por tu pronta respuesta lo voy a probar y te comento
    Gracias
     
  5. juliobrenis

    juliobrenis New Member

    Buenas noches probe lo que publicaste y no bloquea nada
    Me puse a googlear y encontre estas reglas que no les he probado y funcionan con la Version 6.34.3 de Mikrotik lo he probado con Google Chrome, IE y Mozilla... ademas no afecta los servicios de google como gmail, maps. drive. fotos, etc.
    Código (Text):
    /ip firewall filter
    add action=drop chain=forward comment="BLOQUEAR YOUTUBE HTTPS EN TODOS LOS BROWSER DST." disabled=no dst-address=0.0.0.0/0 \
        dst-port=443 layer7-protocol=www.youtube.com protocol=tcp
    add action=drop chain=forward comment="BLOQUEAR YOUTUBE HTTPS EN TODOS LOS BROWSER SRC." disabled=no layer7-protocol=\
        www.youtube.com protocol=tcp src-address=0.0.0.0/0 src-port=443
    add action=drop chain=forward comment="BLOQUEAR YOUTUBE HTTP EN TODOS LOS BROWSER DST." disabled=no dst-address=0.0.0.0/0 \
        dst-port=80 layer7-protocol=www.youtube.com protocol=tcp
    add action=drop chain=forward comment="BLOQUEAR YOUTUBE HTTP EN TODOS LOS BROWSER SRC." disabled=no layer7-protocol=\
        www.youtube.com protocol=tcp src-address=0.0.0.0/0 src-port=80
    Te dejo el enlace para que los puedes revisar o quizas a alguien que lo necesite.
     
    Última modificación por un moderador: 11 de Abril de 2016
  6. juliobrenis

    juliobrenis New Member

    Tambien encontre un Layer 7

    Código (Text):
    ^.*(youtube).*$
    Realize las mismas pruebas.
    Saludos
     
    A MikrotikPeru le gusta esto.
  7. ronaldroberto21

    ronaldroberto21 New Member

    BUENO E PROBADO Y SI FUNCIONA GRAN APORTE
     
    A juliobrenis y MikrotikPeru les gusta esto.
  8. juliobrenis

    juliobrenis New Member

    Despues de mucho tiempo que ya no implementaba reglas de firewall me di con la sorpresa que esta regla que en su debida oportunidad probe y comprobe que funcionaba ahora con las versiones 6.x de routeros ya no es posible bloquear youtube, por esta razón opte por implementar proxy en modo gateway, sin embargo si he podido restringuirlo con la finalidad de que el usuario no logre ver los videos, es decir si llega a cargar la pagina de youtube, pero no llega a visualizar el video por las reglas de mangle y queque simple que puse, las estaré publicando luego.
     
  9. daviddomh

    daviddomh New Member

    Actualmente para captar el tràfico de Youtube yo lo hago asi :

    /ip firewall layer7-protocol
    add name=facebook regexp="^.*(facebook).*\$"
    add name=fbcdn regexp="^.*(fbcdn).*\$"
    add name=googlevideo regexp="^.*(googlevideo).*\$"
    add name=steamcontent regexp="^.*(steamcontent).*\$"
    add name=steampowered regexp="^.*(steampowered).*\$"

    lo hago para redireccionar por diferentes lineas el trafico de steam, youtube y facebook .
     
    A juliobrenis le gusta esto.
  10. mcguti

    mcguti New Member

    Una pregunta compañeros, saben como puedo averiguar las ips de youtube correspondientes a Mexico.
     

Comparte esta página