La importancia del MTU

Tema en 'GNU/Linux' comenzado por MikrotikPeru, 25 de Marzo de 2018.

  1. MikrotikPeru

    MikrotikPeru Well-Known Member

    [​IMG]

    (Maximum Transmission Unit) es la máxima cantidad de datos que puede ser transmitido físicamente en un paquete. Muchas veces tenemos problemas de fragmentacion de paquetes y debemos tener utilidades para verificar el estado de la red.

    Encapsulado PPPoE
    1452 Datos
    20 Cabecera IP
    8 Cabecera ICMP
    20 Tunnel PPP

    Entonces podemos hacer pruebas en una red PPPoE haciendo pruebas.
    Con Conexión PPPoE
    ping 192.95.62.43 -f -l 1452

    Sin conexion PPPoE
    ping 192.95.62.43 -f -l 1472


    Utilidad Linux
    • iputils-tracepath
    Bernardo@RouterOS$ tracepath -n 192.168.50.2
    1: 10.1.0.2 0.059ms pmtu 1500
    2: 10.1.0.1 0.120ms pmtu 1400
    2: 10.0.0.22 0.514ms reached
    Resume: pmtu 1400 hops 2 back 254


    Algun paquete con más de 1400 bytes será fragmentado
     
    Última modificación: 25 de Marzo de 2018
  2. MikrotikPeru

    MikrotikPeru Well-Known Member

    Es un hecho bien conocido que los enlaces VPN tienen un tamaño de paquete más pequeño debido a la sobrecarga de encapsulación. Un paquete grande con MSS que excede el MSS del enlace VPN debe estar fragmentado antes de enviarlo a través de ese tipo de conexión. Sin embargo, si el paquete tiene el indicador DF configurado, no se puede fragmentar y se debe descartar. En los enlaces que han roto el descubrimiento de MTU de ruta (PMTUD), puede dar lugar a una serie de problemas, incluidos los problemas con la transferencia de datos FTP y HTTP y los servicios de correo electrónico.

    En caso de enlace con PMTUD roto, una disminución de los MSS de los paquetes que llegan a través del enlace VPN resuelve el problema. El siguiente ejemplo muestra cómo disminuir el valor de MSS a través de mangle:

    PHP:
    /ip firewall mangle
    add action=change-mss chain=forward new-mss=1410 out-interface=all-ppp passthrough=yes protocol=tcp tcp-flags=syn tcp-mss=1411-65535
    add action=change-mss chain=forward in-interface=all-ppp new-mss=1360 passthrough=yes protocol=tcp tcp-flags=syn tcp-mss=1361-65535
     

Comparte esta página