Migración de Simple Queues a PCQ ( Solución WISP )

Tema en 'Queues' comenzado por MikrotikPeru, 31 de Enero de 2016.

  1. MikrotikPeru

    MikrotikPeru Well-Known Member

    En esta guía veremos como migrar de un esquema tradicional de Simple Queues a PCQ , Con esta configuración lograremos Reducir Reglas y Procesador. Como sabemos Simple Queues se ejecuta de arriba hacia abajo y por ende los usuarios que están en las ultimas reglas presentaran lentitud. Con PCQ se dará una cierta velocidad Total y aparte de ello una Velocidad que tendrán Cada cliente , En caso que llegue a la velocidad total asignada . PCQ entrara en acción ecualizando y brindando velocidades iguales a todo los Usuarios.


    [​IMG]
    ✔ FUNDAMENTOS:

    -¿Qué es Simple Queues y como Funciona ?
    Funciona de manera sencilla con tan solo poner la y o toda una red empieza a limitar. Pero Hay un detalle muy interesante , Todas las Queues se ejecutan de orden jerárquico , Si tienes 1000 reglas para que llegue a la 999 tendra que pasar por todas las anteriores .

    -¿Qué es PCQ y como funciona ?
    Con tan solo Crear dos PCQ podremos limitar y entregar una velocidad limite a cada usuario y como si fuera poco cuando la Velocidad Total este llena PCQ empieza a ecualizar (Dividir el ancho de banda entre todos los conectados )


    -¿Porque Migrar de Simple Queues a PCQ?
    Al migrar tenemos un ecualizado y también ahorraremos recursos en nuestro Mikrotik.



    ✔ 2.LABORATORIO:

    - 2.1 Creando el PCQ
    Bueno es esta parte crearemos dos ecualizadores PCQ , uno es de Dowload como también de upload .Aparte de ello colocaremos la velocidad que les llegara a los clientes.

    [​IMG]


    -2.2 CREANDO EL QUEUES

    [​IMG]

    -2.3 LIMITE DEL QUEUES

    [​IMG]




    Código (Text):
    /queue type
    add kind=pcq name="Download " pcq-classifier=dst-address pcq-dst-address6-mask=\
        64 pcq-rate=1300k pcq-src-address6-mask=64
    add kind=pcq name=Upload pcq-classifier=dst-address pcq-dst-address6-mask=64 \
        pcq-rate=512k pcq-src-address6-mask=64
    /queue simple
    add max-limit=1M/6M name="Red Ecualizada " queue="Upload/Download " target=\
        192.168.100.0/24
     

    Como podemos observar con una sola regla administramos el ancho de banda a todos los clientes , Si deseas tener un diferente plan de velocidad simplemente creas un pcq aparte para poder asociarlo con el pcq del plan creado.
     
    Última modificación: 9 de Febrero de 2016
    A lantiano le gusta esto.
  2. mahehe506

    mahehe506 New Member

    Me gustaría implementarlo en mi red, pero como seria el segundo ya que manejo 2 velocidades 5 y 10 megas. el primer ejemplo lo entiendo, el segundo seria algo así tengo que crear un pcq con nombre diferente y asignar a queues y asignar a la ip del cliente o como seria en este caso, gracias de antemno
     
  3. MikrotikPeru

    MikrotikPeru Well-Known Member

    Claro creas 2 PCQ Diferentes y creas colas diferentes
     
    A rifranco202325 le gusta esto.
  4. ellobobengy

    ellobobengy New Member

    Soy nuevo en el foro, alguien me puede decir para que sirve la limitación en el punto 2.3 LIMITE DEL QUEUES, si en el punto 2.1 Creando el PCQ ya se limito la velocidad
     
  5. MikrotikPeru

    MikrotikPeru Well-Known Member

    Si revisas bien te vas a dar cuenta que limitamos a 6 megas a un red mascara 24 y con PCQ limitamos a cada Ip de la sobre

    Saludos
     
  6. ellobobengy

    ellobobengy New Member

    Gracias por responder, pero de esta manera ya no puedo monitorear el uso de cada cliente, en caso de que quiera hacerlo por cliente ya no tendría que limitarlo desde el simple que cierto?
     
  7. MikrotikPeru

    MikrotikPeru Well-Known Member

  8. lantiano

    lantiano Member

    Disculpa la ignorancia , en el simple queue , como quedaría ???
     
  9. Zosimo

    Zosimo New Member

    si como podria monitoriar alos usuarios
     
  10. ellobobengy

    ellobobengy New Member

    Yo estoy limitando a cada usuario por queue tree, pero no se si esta bien hacerlo de esta forma, haber que dice el master del foro.

    [​IMG]
     

    Archivos adjuntos:

  11. Zosimo

    Zosimo New Member

    Yo n veo queue tree veo simple queue
    Alguna guia para administrar por queue tree
     
  12. lantiano

    lantiano Member

    En la parte 2.1, donde dice Limit 50 y total limit 2000 , que quiere decir eso ???

    Es la cantidad de clientes conectados por esa red o que es ???

    Gracias
     

    Archivos adjuntos:

  13. lantiano

    lantiano Member

    Hola una consulta, si tengo una interface 192.168.1.0/24 y 3 ip´s de ese rango quiero que compartan el mismo ancho de banda , como lo haría ??

    Creo un Queue simple , cogiendo el PCQ creado y modificando en el target por las ips correspondientes ???

    Y claro esta modificando el target de carga y descarga .

    Estaría bien así ????
     
  14. MikrotikPeru

    MikrotikPeru Well-Known Member

    Estamos en ello Zosimo, Este es un caso especial.
     
  15. MikrotikPeru

    MikrotikPeru Well-Known Member

    Hola Lantiano, Limit 50 es el tamano de cola por cadena y Total Limit es el total de colas esto varia depende como eliges el PCQ dst o src.
     
  16. MikrotikPeru

    MikrotikPeru Well-Known Member

    Aja por que le estas dando valores Ya predefinidos ya no debería poner ancho de banda a cada usuario.
     
  17. Zosimo

    Zosimo New Member

    Yo quiero ver como se puede administrar por queue tree y no utilizar el simple queue alguien tendra una guia completa de eso
     
  18. MikrotikPeru

    MikrotikPeru Well-Known Member

    Sabes que no se puede hacer doble QoS en la version 6, al trabajar con queues tree como control de ancho de banda, tendrias que usar otro RB para priorizar trafico a menos que sea la version 5.x. A menos que uses queues simples para controlar ancho de banda por ip y queues tree para qos.

    Saludos,
     
  19. Zosimo

    Zosimo New Member

    pero se puede queue tree y queue simple como dices en la V6 queue tree para Qos ay alguna guia o manual completo
     
  20. MikrotikPeru

    MikrotikPeru Well-Known Member

Comparte esta página