Punto a Punto Bridge Transparente entre dos redes que utilizando MPLS Mikrotik

Tema en 'Wireless' comenzado por MikrotikPeru, 17 de Agosto de 2016.

  1. MikrotikPeru

    MikrotikPeru Well-Known Member

    Visión de conjunto
    Este es un ejemplo muy básico de cómo habilitar MPLS, VPLS establecer el túnel entre dos enlaces inalámbricos y lo utilizan para tender un puente sobre dos redes de forma transparente.

    Hay varias otras maneras de crear este tipo de instalación:

    • Puente usando WDS
    • Tender un puente sobre el uso de EoIP
    • El enfoque de MPLS / VPLS tiene algunas ventajas:

    VPLS túnel es de arriba alrededor del 60% más rápido y menos sobrecabezera que túnel EoIP
    802.11n velocidad está limitada por puentes WDS, este método no tiene tales limitaciones
    Configuración
    Supongamos la configuración de red siguiente:

    [​IMG]
    [​IMG]
    Configuracion en el AP:

    PHP:
    # --configure wireless access point--
    /interface wireless
    set wlan1 disabled=no ssid=MPLS frequency=5180 band=5ghz mode=bridge

    # --configure IP--
    /ip address
    add address=172.16.0.1/30 interface=wlan1

    # --enable LDP--
    /mpls ldp
    set enabled=yes lsr-id=172.16.0.1 transport-address=172.16.0.1
    /mpls ldp interface
    add interface=wlan1

    # --configure VPLS tunnel--
    /interface vpls
    add name=vpls1 remote-peer=172.16.0.2 vpls-id=1:1 disabled=no

    # --add bridge and bridge ports --
    /interface bridge add name=bridge1
    /interface bridge port
    add bridge=bridge1 interface=ether1
    add bridge=bridge1 interface=vpls1
    Configuracion en el CLIENTE:

    PHP:
    # --configure wireless access point--
    /interface wireless
    set wlan1 disabled=no ssid=MPLS band=5ghz mode=station

    # --configure IP--
    /ip address
    add address=172.16.0.2/30 interface=wlan1

    # --enable LDP--
    /mpls ldp
    set enabled=yes lsr-id=172.16.0.2 transport-address=172.16.0.2
    /mpls ldp interface
    add interface=wlan1

    # --configure VPLS tunnel--
    /interface vpls
    add name=vpls1 remote-peer=172.16.0.1 vpls-id=1:1 disabled=no

    # --add bridge and bridge ports --
    /interface bridge add name=bridge1
    /interface bridge port
    add bridge=bridge1 interface=ether1
    add bridge=bridge1 interface=vpls1
    Confirmamos las etiquetas LDP estén activas:

    PHP:
    [admin@MikroTik] /mpls ldp neighbor> print
    Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, V - vpls
    #      TRANSPORT    LOCAL-TRANSPORT PEER           SEND-TARGETED ADDRESSES
    0 DOTV 172.16.0.2   172.16.0.1      172.16.0.2:0   no            172.16.0.2
                                                                                   
    [admin@MikroTik] /mpls ldp neighbor> .. .. forwarding-table print
    Flags: L - ldp, V - vpls, T - traffic-eng
    #   IN-LABEL        OUT-LABELS      DESTINATION    INTERFACE    NEXTHOP
    0   expl-null
    1 V 18                              vpls1
     
    Confirmamos el tunel VPLS este establecido:

    PHP:
    [admin@MikroTik] /interface vpls> monitor vpls1 once
           remote-label: 17
            local-label: 18
          remote-status:
      transport-nexthop: 172.16.0.2
         imposed-labels: 17
     
     
    A darkhammer le gusta esto.
  2. darkhammer

    darkhammer New Member

    1.-¿¿ ya no es nesesario colocar seguridad ya que el per to per es de 1 a 1 =???? ademas de hacer una cabezara mas grande ..
    2.- podrias especificar mejor si en el caso quiero emitir con un AP - y tener dos AP clientes en mpls en id iria 1:2?, podrias apmpliar un poco mas?,, Gracuas por las RESP
     
  3. MikrotikPeru

    MikrotikPeru Well-Known Member

    NVR trae seguridad propio asi es que no necesitas y si te refieres a las etiquetas VPLS asi es.
    si hay dos equipos entones el AP quedaria:

    PHP:
    # --change wireless access point mode to AP Bridge--
    /interface wireless
    set wlan1 mode=ap-bridge

    # --configure second VPLS tunnel--
    /interface vpls
    add name=vpls2 remote-peer=172.16.0.3 vpls-id=2:2 disabled=no

    # --add vpls2 to bridge --

    /interface bridge port
    add bridge=bridge1 interface=vpls2
     
  4. lantiano

    lantiano Member

    Hola esta muy bueno este manual, una consulta.

    Como se podria hacer un enlace Mpls - Vpls , con cliente router ??'

    Gracias
     
  5. lantiano

    lantiano Member

    Hola, estoy intentando implementar esto en un SXT ,de tal manera que quede asi:

    La señal ingrese por wifi (Wlan) en modo MPLS + VPLS , y salga por el ether1 en modo roter y dhcp.

    Pero al momento en que hago el nat del ether1 , se me deshabilita el bridge que se crea con el VPLS y si no configuro el VPLS pues no me da acceso , al igual que si no configuro el NAT.

    Hay alguna otra forma de integrar el envio de datos por MPLS + VPLS y que salga con un ip diferente ???

    Gracias
     
  6. WSJ

    WSJ New Member

    hola amigo !!!

    quisiera me dieras una ayuda por favor...

    estoy tratando de implementar mpls-vpls

    tengo 2 topologia

    1 .RB450 como admin y servidor mpls-vpls con AP RB922 en modo ap bridge los CPE se conectan perfectamente por mpls-vpls aqui va todo perfectamente

    2. RB450 como admin 2 HLG5 mikrotik ptp en modo bridge en el otro extremo un RB922 como ap bridge he aqui "he aqui problema" ningun cliente se puede conectar por mpls-vpls a este 2do AP

    no tengo claro cual es la configuración en los ptp y el ap para llegar al cCPE con mpls

    muchas gracias espero una pronta respuesta...
     
  7. lantiano

    lantiano Member

    Hola se puede implementar en un 750Gl modo puente en una interfas y modo router en otra ???. Gracias
     

Comparte esta página