QoS - forward vs prerouting

Tema en 'Queues' comenzado por JezuTIK, 6 de Abril de 2017.

  1. JezuTIK

    JezuTIK New Member

    Buenas a todos,

    Soy nuevo por aquí, aquí les lanzó mi consulta:

    Quería consultarles una duda, yo siempre he usado la cadena prerouting (marcar antes de la decisión de routing) pero me ha generado duda este vídeo del mum:


    Min. 26:14

    Jorge Filipo dice textualmente: "Control de tráfico cadena forward" ...

    Es mejor usar forward o prerouting?
    ¿porque usar forward o prerouting?


    Saludos.
     
  2. JezuTIK

    JezuTIK New Member

    @MikrotikPeru
     
  3. MikrotikPeru

    MikrotikPeru Well-Known Member

    Excelente Expo de Jorge Filipo,
    Pero hay algo que no estas entiendiendo cuando quieres trabajar decisión de routing debes trabajar si o si en la cadena PREROUTING o alguien lo ha hecho en forward ???
    Segundo detalle importante, El QOS se arma depende el esquema que necesites:
    Ejemplo1: La necesidad es solo armar PRIORIZACION DE TRAFICO WAN - LAN (Trafico de Internet convencional) Solo necesitamos marcar en cadenas forward.
    Ejemplo2: Se requiere dar Qos a un WEBPROXY mikrotik por usuario que necesitarias ? para este caso seria cadenas prerouting y output.
    Conclusion: Es deacuerdo al caso que requieras.

    Saludos,
     
  4. JezuTIK

    JezuTIK New Member

    Y por qué no un pre-routing y marcar in-interface?

    He visto muchos ejemplos, la gente usa pre-routing sin utilizar in-intrface ni address-list, ¿no es una locura marcar todo el tráfico en todos lados?
     
  5. MikrotikPeru

    MikrotikPeru Well-Known Member

    Una marca PREROUTING, sin un origen o destino no tiene sentido o sobrescribes reglas que quizas ni te des cuenta, básicamente siempre se debe especificar una interface de donde se origina o almenos un IP origen o grupo de IP addresses list.
     
  6. JezuTIK

    JezuTIK New Member

    Gracias, una nueva cuestión.

    Esquema:

    [​IMG]

    Para hacer QoS (en el RB750gr3) tanto en la LAN (ether2) y en la VLAN (Vlan 11 - AP), en vez de usar en el Queue Tree las interfaces HTB para cada uno (ether2 y vlan11), en la bajada uso la HTB virtual "global" y para la subida SÍ marco la ether1 que es la interface conectada al ISP, mi duda es si este marcado es correcto ...

    Código:

    Primero os muestro mi marcado de paquetes:

    Código (Text):
    /ip firewall mangle

    add chain=prerouting action=mark-connection new-connection-mark=mc_youtube \
    passthrough=yes connection-state=new dst-address-list=Youtube in-interface=VLAN_11

    add chain=prerouting action=mark-connection new-connection-mark=mc_youtube
    passthrough=yes connection-state=new dst-address-list=Youtube in-interface=ether2

    add chain=prerouting action=mark-packet new-packet-mark=pk_youtube
    passthrough=no connection-mark=mc_youtube
    Aquí si os fijáis uso in-interface para marcar conexiones tanto para ether2 y vlan11.

    Segundo os muestro el queue type y queue tree:

    Código (Text):
    /queue type

    add name="QoS_download" kind=pcq pcq-rate=0 pcq-limit=30KiB pcq-classifier=dst-address \
         pcq-total-limit=900KiB pcq-burst-rate=0 pcq-burst-threshold=0 \
         pcq-burst-time=10s pcq-src-address-mask=32 pcq-dst-address-mask=32\
         pcq-src-address6-mask=64 pcq-dst-address6-mask=64

    add name="QoS_upload" kind=pcq pcq-rate=0 pcq-limit=30KiB pcq-classifier=src-address \
         pcq-total-limit=900KiB pcq-burst-rate=0 pcq-burst-threshold=0 \
         pcq-burst-time=10s pcq-src-address-mask=32 pcq-dst-address-mask=32 \
         pcq-src-address6-mask=64 pcq-dst-address6-mask=64
    Ahora el Queue tree:

    Para la subida, parent interface HTB "ether1"
    Código (Text):
    / queue tree

    add name="QoS_up" parent=ether1 packet-mark="" limit-at=1024k queue=QoS_upload
         priority=8 max-limit=2048k burst-limit=0 burst-threshold=0 burst-time=0s \
         bucket-size=0.1

    add name="5-Youtube_d" parent=QoS_up packet-mark=pk_youtube limit-at=512k \
         queue=QoS_up priority=5 max-limit=2048k burst-limit=0 burst-threshold=0 \
         burst-time=0s bucket-size=0.1
    Para la bajada, parent HTB virtual "global"
    Código (Text):
    / queue tree
    add name="QoS_down" parent=global packet-mark="" limit-at=1024k queue=QoS_download
         priority=8 max-limit=2048k burst-limit=0 burst-threshold=0 burst-time=0s \
         bucket-size=0.1

    add name="5-Youtube_d" parent=QoS_down packet-mark=pk_youtube limit-at=512k \
         queue=QoS_download priority=5 max-limit=2048k burst-limit=0 burst-threshold=0 \
         burst-time=0s bucket-size=0.1
    El problemas es que la subida me la marca también como bajada, si veo un vídeo de Youtube (bajada) me lo marca bien, pero si subo un vídeo a YouTube a 10Mb, me marca tanto 10Mb de bajada como de subida, entiendo que será por el global?
     
  7. MikrotikPeru

    MikrotikPeru Well-Known Member

    A JezuTIK le gusta esto.
  8. JezuTIK

    JezuTIK New Member

Comparte esta página