VPN ipsec site to site un extremo con ip dinamica

Tema en 'MikroTik RouterBOARD' comenzado por alebrust, 19 de Abril de 2017.

  1. alebrust

    alebrust New Member

    Hola mi nombre es Alejandro espero me puedan ayudar, puedo formar una VPN site2site con ips fijas sin problemas, pero me gustaría saber como hacer para un escenario donde uno de los extremos tiene IP publica dinamica (dhcp). La verdad es que probe un par de links pero ninguno me funciono. Alguien me podria dar una mano/guia por donde empezar?
    Gracias x adelantado.
     
  2. MikrotikPeru

    MikrotikPeru Well-Known Member

    La lógica de lo que quieres hacer es con script, básicamente que consulte cada cierto tiempo tome el IP la guarde en una variable, luego la pegue en el Peer del IPSec, y eso solo suceda solo cuando compare que cambio el IP.
     
  3. MikrotikPeru

    MikrotikPeru Well-Known Member

    Donde el peer debe estar comentado como "myIPsec"

    PHP:
    ##############Script Settings##################
    :local RemoteNOIPHost "mikrotik.com.pe"
    :local IPsecComment "myIPsec"
    ###############################################

    :local TmpIP [/ip ipsec peer get [find comment="$IPsecComment"] address]
    :local OldIP [:pick "$TmpIP" 0 ([:len $TmpIP] - 3)]
    :local NewIP [:resolve $RemoteNOIPHost]

    :if ($NewIP != $OldIP) do={
      :log info "IPsec: Remote IP changed: Old: $OldIP, New: $NewIP"
      /ip ipsec policy set [find comment="$IPsecComment"] sa-dst-address=$NewIP
      :log info "IPsec: Policy updated with new remote IP"
      /ip ipsec peer set [find comment="$IPsecComment"] address=$NewIP
      :log info "IPsec: Peer updated with new remote IP"
    }
    Saludos,
     

Comparte esta página