Script para crear lista de celulares conectados y bloquear paginas (Fb)

Tema en 'Scripting & Scheduling' comenzado por Jose Alfaro, 17 de Enero de 2020.

  1. Jose Alfaro

    Jose Alfaro New Member

    Buenas comunidad, espero me puedan ayudar, ocupo crear un script para hacer un addresslist de los celulares conectados a mi red, y que esta lista se actualice al conectarse otro celular o que se actualice automáticamente
    A esta lista se le debe negar el acceso a facebook u otras paginas en cierto horario (8 a 12 y 13 a 18 )
    Buscando encontré un par de scripts que detecta y recoge los celulares celulares conectados, pero al final los bloquea o filtra del todo.
    se que se podrían modificar para realizar lo que ocupo, pero tengo el conocimiento para hacer las modificaciones requeridas.

    mi configuración
    WAN - RB951g-2HnD (wifi off) ---- switch --- varios ap (nada pro) . . . . . . celulares y portatiles..

    scripts encontrados:
    ########## INICIO DEL SCRIPT
    :local DHCPSERVER "dhcp1";

    :foreach i in=[/ip dhcp-server lease find dynamic=yes active-server=$DHCPSERVER] do={
    :local DhcpDynMAC [/ip dhcp-server lease get $i mac-address];
    :local DhcpDynCLIENTID [/ip dhcp-server lease get $i active-client-id];
    :local DhcpDynHOST [/ip dhcp-server lease get $i host-name];
    :local phoneNAME [:pick $DhcpDynHOST 0 4];

    :if ( ($phoneNAME="BLUS") || ($phoneNAME="iPad") || ($phoneNAME="andr") || ($phoneNAME="Andr") || ($phoneNAME="Wind") ||

    ($phoneNAME="iPho") || ($phoneNAME="BLAC") ) do={
    /ip dhcp-server lease add block-access=yes mac-address="$DhcpDynMAC" use-src-mac=yes comment="$DhcpDynHOST"

    server="$DHCPSERVER" client-id="$DhcpDynCLIENTID";
    }
    }
    /ip dhcp-server lease remove [find host-name~"BLUS*"]
    /ip dhcp-server lease remove [find host-name~"android*"]
    /ip dhcp-server lease remove [find host-name~"Android*"]
    /ip dhcp-server lease remove [find host-name~"Windows*"]
    /ip dhcp-server lease remove [find host-name~"iPad*"]
    /ip dhcp-server lease remove [find host-name~"iPhone*"]
    /ip dhcp-server lease remove [find host-name~"BLACKBERRY*"]
    ############## FIN DEL SCRIPT

    # # SCRIPT: FILTRAR CELULARES EN BRIDGE

    :local DHCPSERVER "dhcp_alumnos";
    :local BRIDGEFILTER "bridge-alumnos";

    :foreach i in=[/ip dhcp-server lease find dynamic=yes active-server=$DHCPSERVER] do={
    :local DhcpDynIP [/ip dhcp-server lease get $i address];
    :local DhcpDynMAC [/ip dhcp-server lease get $i mac-address];
    :local DhcpDynHOST [/ip dhcp-server lease get $i host-name];
    :local IfMacExist [/interface bridge filter find src-mac-address="$DhcpDynMAC/FF:FF:FF:FF:FF:FF"];
    :local phoneNAME [:pick $DhcpDynHOST 0 4];

    :if ( ($phoneNAME="iPad") || ($phoneNAME="S410") || ($phoneNAME="Andr") || ($phoneNAME="LANI") || ($phoneNAME="Ipho") ||

    ($phoneNAME="S220") || ($phoneNAME="S120") || ($phoneNAME="BLUS") || ($phoneNAME="iPod") || ($phoneNAME="andr") ||

    ($phoneNAME="Wind") || ($phoneNAME="iPho") || ($phoneNAME="BLAC") || ([:len $DhcpDynHOST]=0) ) do={
    :if ($IfMacExist != "") do={
    # :log error ("Filtrando telefono... ".$DhcpDynMAC. " Ya existe")
    } else= {
    /interface bridge filter add action=drop chain=input in-bridge=$BRIDGEFILTER src-mac-

    address="$DhcpDynMAC/FF:FF:FF:FF:FF:FF" comment=$DhcpDynHOST;
    :log warning ("Se filtro un nuevo dispositivo " . $phoneNAME . " MAC: " . $DhcpDynMAC);
    }
    }
    }
    ############## FIN DEL SCRIPT
     
  2. Pseverini

    Pseverini New Member

    Buenas Jose, me interesa tu hilo porque yo estoy por realizar un trabajo en el que necesito hacer una restriccion de ancho de banda y no de bloqueo total.
    yo entiendo el codigo en un 80% asi que tratare de colaborar y en unos dias pondre todo en practica y si aun te interesa podemos seguir el hilo hasta lograr lo que queremos.
    /interface bridge filter add action=drop chain=input in-bridge=$BRIDGEFILTER src-mac- <----yo creo que aca lo deberias mandar a un Address list para posterior hacer el filtrado por firewall. y si neceesitas como yo hacer el QUEUE TREE con los niveles de Ancho de banda que le daremos a esa lista. no se si hiciste algo ma.
     
  3. Jose Alfaro

    Jose Alfaro New Member

    Hola!, Gracias Pseverini , pues si me interesa seguir el hilo, ayudarnos y ayudar a la comunidad, en mi caso por que es una solución que puedo agregar como plus a mis clientes.
    En cuanto pueda cambiare el parámetro para agregarlo a un address list y filtrado... lo del QUEUE TREE si se me hace un poco mas complicado.
     

Comparte esta página